読者です 読者をやめる 読者になる 読者になる

weblog of key_amb

主にIT関連の技術メモ

openssl コマンドで POODLE 脆弱性を確認する

CLIツール ネットワーク 情報セキュリティ

openssl コマンドにはいろんなサブコマンドがありますが、その内の s_client というコマンドで SSL/TLS クライアントを動かすことができます。

指定のサイトで SSLv3 が動いているか(POODLE脆弱性があるか)は以下のコマンドで確認できます。

openssl s_client -connect example.com:443 -ssl3

参考